The upgrade of the Microsoft Exchange component may not succeed when you upgrade SBS 2000 to SBS 2003 (888942)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you upgrade Microsoft Small Business Server (SBS) 2000 to SBS 2003, the upgrade of the Microsoft Exchange component may not succeed. Additionally, you may experience the following behaviors:
  • You are prompted to replace one or more files that have a later version date than the files that SBS 2003 installs.
  • You receive the following error message:
    Setup failed while installing subcomponent "microsoft exchange Information store service" with error code 0x80040154.
  • Information that is similar to the following is recorded in the Exchange Server Setup Process.log file:
    [20:31:16] Creating Microsoft Search application
    [20:31:16] Creating search admin component
    [20:31:16] CAtomMDB::ScInstallCreateSearchApplication 
    (f:\titanium\admin\src\udog\exsetdata\components\server\a_mdb.cxx:1932)
    Error code 0X80040154 (340): Class not registered
    [20:31:16] Leaving CAtomMDB::ScInstallCreateSearchApplication
    [20:31:16] Entering CAtomMDB::ScPauseSearchFullPopulation
    [20:31:16] Entering CAtomMDB::ScGetBuildCatalogsInterface
    [20:31:16] Creating search admin component
    [20:31:16] CAtomMDB::ScGetBuildCatalogsInterface 
    (f:\titanium\admin\src\udog\exsetdata\components\server\a_mdb.cxx:2210)
    Error code 0X80040154 (340): Class not registered
    [20:31:16] Leaving CAtomMDB::ScGetBuildCatalogsInterface

CAUSE

This problem may occur when a program has replaced some Microsoft Search DLL files with files that have incorrect version numbers.

RESOLUTION

To resolve this problem, reregister the Oleaut32.dll file, and then run the SBS 2003 Setup program again. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then press ENTER.
  2. Type cd \windows\system32, and then press ENTER.
  3. Type regsvr32 oleaut32.dll, and then press ENTER.
  4. Run the SBS 2003 Setup program again.

Modification Type:MajorLast Reviewed:12/22/2004
Keywords:kbtshoot kbprb KB888942 kbAudITPRO