You receive an error message when you try to upgrade to Microsoft Operations Manager 2005 (888833)



The information in this article applies to:

  • Microsoft Operations Manager 2005

SYMPTOMS

You receive the following error message in the MachineNameAgentInstall.log file or in the MOMComponent .log file:
ForceKillMOMHost: Setup failed to kill MOMHost process.
Error Code: 0x80070424.
This symptom occurs in either of the following scenarios:
  • You try to upgrade a Microsoft Operations Manager (MOM) 2005 Management Server or Management Agent component.
  • You try to perform a new installation of the MOM 2005 Management Server or Management Agent components after you have removed an earlier version of these MOM components.
The MOM Setup process rolls back the changes, and then generates an error message that the installation has failed.

Note The MachineNameAgentInstall.log file is located in the MOM Installation folder\AgentLogs folder. The MOMComponent .log file is located in the Documents and Settings\Administrator\Local Settings\Temp\ folder.

CAUSE

This problem occurs because the MOM service has been deleted from the previous MOM installation. When the MOM 2005 Setup program cannot find the previous MOM service, it generates the error message that is described in the "Symptoms" section.

This problem occurs if you try to perform a new installation of MOM 2005 after you have removed an earlier version of MOM. In this case, the MOMhost process may not be present on the computer, but the Windows installer database on the computer has marked the MOMhost process as residing on the computer. In this case, the MOM Setup program uses the data that is contained in the Windows Installer database. The MOM Setup program then sees that the MOMhost process is present and tries to kill the process.

This problem can be caused by a failed upgrade. In this case, the MOM service may not be stopped correctly, or the Data Access Server (DAS) account may not be able to access the MOM database.

WORKAROUND

To work around this problem, use one of the following methods.

If you are upgrading a MOM component to MOM 2005

  1. Use Task Manager to stop any monitoring processes that are monitoring MOM and that are holding the Momhost process.

    Note If that does not resolve the problem, you may have to restart the computer to release the monitoring process.
  2. If restarting the computer does not solve the problem, make sure that you have a good backup of your existing MOM components files. For information about how to do this, download the MOM 2005 Deployment Guide. To do this, visit the following Microsoft Web site:
  3. Follow steps 1 to 5 in the "If you are performing a new installation of MOM components after you remove an earlier version" section to remove the previous MOM components and MOM data in the Windows Installer database.

    Important Complete steps 1 to 5 before you restore your MOM computer and either try the MOM upgrade process again or try the installation again.

If you are performing a new installation of MOM components after you remove an earlier version

Use the Sc.exe tool to make sure that the MOM 2005 or the MOM 2000 OnePoint services are not present on your computer. The Sc.exe tool is contained in the Windows 2000 Resource Kit. To make sure that the MOM 2005 or the MOM 2000 OnePoint services are not present on your computer, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type sc.exe query mom, and then press ENTER.
  3. At the command prompt, type sc.exe query onepoint, and then press ENTER.
  4. If you receive the following error message, you must use the MOM 2005 Resource Kit Cleanupmom.exe tool with the /z All parameter:
    The specified service does not exist as an installed service.
    The cleanupmom.exe /z All command removes all the MOM components and the MOM-related data that is contained in the Windows Installer database. The Cleanupmom.exe tool also removes all the MOM 2005 configuration information.
  5. Try to install MOM 2005 again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To download the MOM 2005 Resource Kit, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB888833 kbAudITPRO