FIX: Users who do not have List Folder/Read Data permission can see the file list for an NFS file share from some Network File System clients in Windows Storage Server 2003 (888618)



The information in this article applies to:

  • Microsoft Windows Storage Server 2003

SYMPTOMS

From some Network File System (NFS) clients, users who do not have List Folder/Read Data permission can see the file list for an NFS file share in Microsoft Windows Storage Server 2003. NFS clients that experience this problem include UNIX and Linux clients.

CAUSE

This problem occurs when the following conditions are true:
  • Client-side caching is enabled.
  • Server for NFS returns incorrect information to ACCESS requests.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name     
   ----------------------------------------------------------------
   29-Oct-2004  21:45  8.0.2254.6  423,552  Nfssvr.sys                                          

WORKAROUND

To work around this problem, use one of the following methods:
  • Require the NFS clients to use only version 2 of the NFS protocol.
  • Require Server for NFS to use only version 2 of the NFS protocol.

    NoteTo require Server for NFS to use only version 2 of the NFS protocol, open the administration tool, click Server for NFS, click Server Settings, and then click to clear the Enable NFS v3 support check box. Alternatively, type nfsadmin server config enablev3=no at a command prompt.
  • Disable the client-side cache in Linux or in UNIX.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information about Windows Services for UNIX, visit the following Microsoft Web site: For additional information about the standard terminology that is used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbUNIXService KB888618 kbAudITPRO