An error message may be logged in the Windows Installer debug log when you try to install a program that uses Windows Installer 3.0 (888310)



The information in this article applies to:

  • Microsoft Windows Installer 3.0, when used with:
    • Microsoft Windows XP Service Pack 2, when used with:
      • Microsoft Windows XP Home Edition
      • Microsoft Windows XP Professional
    • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you try to install a program that uses Microsoft Windows Installer 3.0 on a Microsoft Windows XP-based computer, the installation may fail. Additionally, the following error message may be logged in the Windows Installer debug log:
DEBUG: Error 2203: Database: C:\WINDOWS\Installer\<file>.msi. Cannot open database file. System error -2147287008
Note In this error message, <file> is a placeholder for the name of the .msi file (package) that you are trying to install.

CAUSE

This problem occurs because the StgCreateDocfile function fails with a STG_E_SHAREVIOLATION return value. When this occurs, the CHandle class cannot find the file handle in the global list for a database file that is required to install the program.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Msi.dll3.0.3790.25392,804,22427-Oct-200417:04x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about How to Enable Windows Installer Logging in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

314852 How to enable Windows Installer logging in Windows XP

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWin2000preSP5fix kbpubtypekc KB888310 kbAudDeveloper kbAudITPRO