You receive an error message when you try to install a shared network printer on a Windows Server 2003-based or Windows XP SP1-based computer (888046)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

SYMPTOMS

If you try to install a shared network printer, you experience symptoms if the following conditions are true:
  • You have a shared network printer that is installed on a Microsoft Windows 2000 Advanced Server-based print server.
  • You try to install the shared network printer locally on a computer that is part of a Windows domain.
  • You try to install the shared network printer locally on a computer that is running one of the following operating systems:
    • Microsoft Windows XP Service Pack 1 (SP1)
    • Microsoft Windows Server 2003
In this scenario, you experience the following symptoms if you try to install a shared network printer:
  • If you try to install the printer on a Windows XP SP1-based client by using the Add Printer Wizard or by using the printer share name from the \\PrintServerName\PrinterShareName location, you receive the following error message:
    A policy is in effect on your computer which prevents you from connecting to this print queue. Please contact your system administrator.
  • If you try to install the printer on a Windows Server 2003-based client by using the Add Printer Wizard, you receive the following error message when you click Finish to complete the printer installation:
    Unable to Install Printer. The printer driver is not compatible with a policy enabled on your computer that blocks Windows NT 4.0 drivers. If you want to use this driver, contact your system administrator about disabling this policy.

CAUSE

This issue occurs if the printer driver that is installed on the print server is a third-party printer driver. You cannot install a shared network printer that has a third-party printer driver locally on a Windows XP SP1-based computer if you are a regular user or a member of the Power Users group. Windows XP SP1 does not permit regular users or members of the Power Users group to install third-party drivers. In Windows XP SP1, only the following people have permission to install a third-party driver:
  • Local administrator
  • Members of the Administrators group
  • Members of the Power Users group with the "Load and unload device drivers" policy permission
If the Windows XP SP1-based computer is joined to a Microsoft Windows NT 4.0-based domain, regular users and members of the Power Users group can install third-party printer drivers to the Windows XP SP1-based client computer. You may experience issues in installing a third-party printer driver on a Windows XP SP1-based computer if the Windows XP SP1-based computer is part of a workgroup or part of a Microsoft Windows 2000-based domain.

In Windows Server 2003, you cannot install a shared network printer locally if the printer driver that is installed on the print server uses third-party Kernel mode printer drivers. A policy setting in Windows Server 2003 prevents users from installing printers that use third-party Kernel mode print drivers.

RESOLUTION

To resolve this issue, modify the Group Policy settings for the Group Policy object (GPO) that has printer policies defined for the domain users on the domain controller. To do this, follow these steps:
  1. Configure the Load and unload device drivers policy permission for the Power Users group. To do this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
    2. In the left pane, right-click your domain name, and then click Properties.
    3. Click the Group Policy tab, click the GPO that you want to modify, and then click Edit.
    4. In Group Policy Object Editor, locate and then click the Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment folder.
    5. In the right pane, locate and then double-click Load and unload device drivers.
    6. Click to select the Define these policy settings check box, and then click Add User or Group to add the Power Users domain group.
    7. In the Add User or Group dialog box, click Browse to locate the Power Users domain group. Under Enter the object names to select, type Power Users, and then click Check Names to resolve the group name. Click OK two times.
    8. Click OK to close the Load and unload device drivers Properties dialog box.
  2. Turn off the Disallow installation of printers using kernel-mode drivers policy. To do this, follow these steps:
    1. In the left pane, locate and then click the Computer Configuration\Administrative Templates\Printers folder.
    2. In the right pane, locate and then double-click Disallow installation of printers using kernel-mode drivers, click Disabled, and then click OK.
  3. Disable the Point and Print Restrictions policy. To do this, follow these steps:
    1. In the left pane, locate and then click the User Configuration\Administrative Templates\Control Panel\Printers folder.
    2. In the right pane, locate and then double-click Point and Print Restrictions, click Disabled, and then click OK.
  4. On the File menu, click Exit.
  5. Click Start, click Run, type cmd.exe, and then click OK.
  6. At the command prompt, type gpupdate /force, and then press ENTER.
  7. Repeat steps 5 and 6 on the Windows XP SP1-based and Windows Server 2003-based client computers of the domain.

MORE INFORMATION

For more information about printer installation related issues in Windows XP and Windows Server 2003, click the following article numbers to view the articles in the Microsoft Knowledge Base:

326473 You are prompted for administrator credentials when you try to install a plug and play printer

282011 Printer driver is not compatible if a policy is enabled on your computer

319939 Description of the Point and Print Restrictions policy setting in Windows Server 2003 and Windows XP

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:8/2/2006
Keywords:kbwinservperf kbFilePrintservices kb3rdparty kbtshoot KB888046 kbAudITPRO