Your domain user name may not be accepted in Windows Server 2003 or in Windows XP (887710)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium) 2003

SYMPTOMS

When you enter your domain credentials in the applicable logon dialog box, your domain user name may not be accepted. This symptom may occur when you try to start certain programs, such as Microsoft Outlook. It may also occur when you use the Connect As component to access a shared folder or another a shared resource.

For example, when you use the Connect As component to access a shared folder, you receive a notification message in the Connect As dialog box that is similar to the following: Examples:
User Name
username@domain
DOMAIN\username

CAUSE

This problem occurs when the user principal name (UPN) suffix contains only numbers. For example, a UPN such as UserName@1234 generates this problem. The credential manager component in Microsoft Windows Server 2003 and in Microsoft Windows XP does not support a numeric-only UPN suffix.

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 32-bit versions

   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   22-Oct-2004  16:31  5.2.3790.224      162,816  Credui.dll       

Windows Server 2003, Enterprise Edition for Itanium-based Systems

   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   22-Oct-2004  16:31  5.2.3790.224      162,816  Credui.dll       

Windows XP hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP 32-bit versions

   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   20-Dec-2004  18:22  5.1.2600.1615     158,720  Credui.dll       
   20-Dec-2004  18:22  5.1.2600.1615     681,984  Lsasrv.dll       
   20-Dec-2004  18:11  5.1.2600.2586     163,840  Credui.dll       
   20-Dec-2004  18:11  5.1.2600.2586     721,920  Lsasrv.dll       

Windows XP Professional 64-Bit Edition (Itanium) versions

   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   20-Dec-2004  18:22  5.1.2600.1615     158,720  Credui.dll       
   20-Dec-2004  18:22  5.1.2600.1615     681,984  Lsasrv.dll       
   20-Dec-2004  18:11  5.1.2600.2586     163,840  Credui.dll       
   20-Dec-2004  18:11  5.1.2600.2586     721,920  Lsasrv.dll       

WORKAROUND

To work around this problem, change the UPN suffix so that it does not exclusively contain numbers. For example, use "1234.com" as a suffix. For additional information about UPN suffix support, click the following article number to view the article in the Microsoft Knowledge Base:

243629 How to add UPN suffixes to a forest

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB887710 kbAudITPRO kbAudEndUser