The TCP session does not close until you run the "net session /d" command to delete the SMB session on the file server on a Windows Server 2003-based computer (887707)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

On a Microsoft Windows Server 2003-based computer, you open files from the network. These files are still locked after you log off the client computer. If you examine the Transmission Control Protocol (TCP) sessions by using the netstat command, you see a TCP session that is similar to the following:
File server:  
 
  TCP    xxx.xxx.xxx.xxx:445     xxx.xxx.xxx.xxx:3572    CLOSE_WAIT
 
Client:
 
  TCP    xxx.xxx.xxx.xxx:3572    xxx.xxx.xxx.xxx:445     FIN_WAIT_2
The TCP session does not close until you run the net session /d command to delete the Server Message Block (SMB) session on the file server.

CAUSE

This issue occurs because of a problem in the Tcpip.sys file. This problem causes the TCP session to remain open.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Feb-2005  00:45  5.2.3790.280      336,896  Tcpip.sys
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Feb-2005  08:39  5.2.3790.280      977,920  Tcpip.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was corrected in Microsoft Windows Server 2003 Service Pack 1.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

137984 TCP Connection States and Netstat Output


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB887707 kbAudITPRO