Language detection problems with Japanese KANJI characters in PowerPoint 2002 presentations (887611)



The information in this article applies to:

  • Microsoft PowerPoint 2002

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you work with Japanese KANJI characters, you may experience one or more of the following symptoms:
  • When you open an .mhtl file that contains Japanese KANJI characters in Microsoft Internet Explorer 6.0 or a later version on a computer that is running Microsoft Windows 2000, some characters may appear as a white square instead of the correct character.
  • When you open an .mhtl file that contains Japanese KANJI characters in Internet Explorer 6.0 or a later version on a computer that is running a Microsoft Windows operating system other than Windows 2000, the text may not be detected in the correct language.
  • When you copy plain text from another program such as Notepad and then paste the text to a Microsoft PowerPoint 2002 presentation, Japanese KANJI characters are pasted as Chinese text instead of as Japanese text.

CAUSE

This problem may occur if the language auto-detection of five or more Japanese KANJI characters is incorrectly recognized as Chinese language characters.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the PowerPoint 2002 post-Service Pack 3 Hotfix Package that is dated October 31, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

887610 Description of the PowerPoint 2002 post-Service Pack 3 hotfix package: October 31, 2004



After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the DisablePasteLanguageAutodetect registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To enable this hotfix, follow these steps:
  1. Quit PowerPoint 2002.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\PowerPoint\Options

  4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click DWORD Value.
  5. Type DisablePasteLanguageAutodetect, and then press ENTER.
  6. Right-click DisablePasteLanguageAutodetect, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. On the File menu, click Exit to quit Registry Editor.

Modification Type:MinorLast Reviewed:4/7/2006
Keywords:kbOfficeXPpostSP3fix kbQFE kbbug kbfix KB887611 kbAudITPRO kbAudEndUser