A new server that you connect to your domain does not receive the static IP address that you assigned in Windows Small Business Server 2003 (887307)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

If you finish the following steps, your new server does not have the static IP address that you configured by using the Set Up Server Wizard:
  1. You use the Microsoft Windows Small Business Server (SBS) 2003 Set Up Server Wizard to configure a new server with a static IP address in your domain.
  2. On the new server, you visit the following Web site:

    http://SmallBusinessServerName/ConnectComputer

  3. You click Connect to the network now to start the Small Business Server Network Configuration Wizard.
  4. You follow the steps in the Small Business Server Network Configuration Wizard to configure the new server.
This symptom occurs when you log on to the new server after it restarts. This new server has a dynamic IP address instead of a static IP address. The Sbsmig.log file contains an entry that is similar to the following:

ChangeIPAddress() - GetEnabledOnlyNICGuid() failed - [-2147024809]
ChangeIPAddress() -- calling _SetIPAddress( 10.0.0.101, 255.0.0.0 )
ChangeIPAddress() -- _SetIPAddress() failed, hr == [-214724894]

Note The Sbsmig.log file is located in the "%ProgramFiles%\Microsoft Windows Small Business Server\Clients" folder on the server computer that you connected to your Windows SBS domain.

CAUSE

This problem occurs if the following conditions are true:
  • The computer that you connect to your Windows SBS domain has more than one network adaptor installed.
  • One or more of the network adaptors is disconnected from the network.
  • These disconnected network adaptors are not disabled in Windows.
In this scenario, the Windows SBS Setup program may try to connect to the new server computer by using a network adaptor that is not connected to a network. Therefore, the static IP address assignment is not successful.

RESOLUTION

To resolve this problem, disable disconnected network adaptors in a computer before you connect that computer to the Windows SBS domain. To disable a network adaptor, click Start, point to Control Panel, point to Network Connections, right-click the disconnected network connection, and then click Disable.

Note A disconnected network adaptor has a red X over the network icon.

WORKAROUND

To work around this problem, manually assign the static IP address to the connected network adaptor. To do this, follow these steps:
  1. Click Start, point to Control Panel, point to Network Connections, right-click the connected network connection, and then click Properties.
  2. Double-click Internet Protocol (TCP/IP).
  3. Click Use the following IP address, and then type the IP address, the subnet mask, and the default gateway information in the corresponding boxes.
  4. Click Use the following DNS server addresses, and then type the IP address of your Windows SBS-based computer in the Preferred DNS server box.
  5. Click OK two times.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:11/22/2004
Keywords:kbtshoot kbprb KB887307 kbAudITPRO