WMI may stop responding when it tries to retrieve hard disk information in Windows 2000 (884578)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Your Windows Management Instrumentation (WMI) query may stop responding. This problem may occur when you use WMI to retrieve hard disk drive information. Additionally, the Framework.log log file may contain multiple entries with the following information:
Failed to IOCTL_DISK_GET_DRIVE_LAYOUT device DiskID (170) DateTime Thread: ThreadNumber
Note The Framework.log file is located in the %windir%\System32\Wbem\Logs folder.

CAUSE

This problem is caused by an update to the Cimwin32.dll file. See the "Resolution" section for a list of Microsoft Knowledge Base articles that describe updates that may produce this problem.

RESOLUTION

Hotfix information

A newer version of this hotfix is available. For additional information about the newer hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

889405 The process that runs a WMI statement stops responding on a Windows 2000 Service Pack 3 or later-based computer

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace another hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Sep-2004  04:32  1.50.1085.6972  1,093,727  Cimwin32.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB884578 kbAudITPRO