You may receive a "Preparing to install" Windows Installer message when you start Visual Studio 2005 or Visual Studio .NET (884463)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you start Microsoft Visual Studio 2005 or Microsoft Visual Studio .NET, you may receive the following Microsoft Windows Installer message: Preparing to install...This message appears for a few seconds. Then, Visual Studio 2005 or Visual Studio .NET closes and the message disappears.

CAUSE

This behavior occurs when the license registry keys for the Microsoft Office 2000 component are missing.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this behavior, you must export the missing registry subkeys from a computer that has a working version of Visual Studio 2005 or of Visual Studio .NET installed and then import the missing registry subkeys to the computer that is experiencing this behavior.

Import the following registry subkey, depending on the version of Visual Studio that you have:
  • Microsoft Visual Studio 2005, all editions

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{20610409-CA18-41A6-9E21-A93AE82EE7C5}

  • Microsoft Visual Studio .NET 2003
    • Professional Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{20610409-CA18-41A6-9E21-A93AE82EE7C5}

    • Enterprise Architect Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{E05F0409-0E9A-48A1-AC04-E35E3033604A}

    • Enterprise Developer Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{60600409-EA9B-45E9-A468-2C68C8DE70DF}

  • Microsoft Visual Studio .NET 2002, all editions

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{005F0409-6759-11D5-A54F-0090278A1BB8}

For more information about how to import and export registry subkeys, visit the following Microsoft Web site:

STATUS

This behavior is by design.

MORE INFORMATION

Steps to reproduce the behavior

  1. Install Visual Studio 2005 or Visual Studio .NET.
  2. Click Start, click Run, type regedit in the Open box, and then click OK.
  3. Delete the ProductID entry and the DigitalProductID entry from the following registry subkey, depending on the version of Visual Studio that you have:

    Visual Studio 2005, all editions

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{20610409-CA18-41A6-9E21-A93AE82EE7C5}

    Visual Studio .NET 2003
    • Professional Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{20610409-CA18-41A6-9E21-A93AE82EE7C5}

    • Enterprise Architect Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{E05F0409-0E9A-48A1-AC04-E35E3033604A}

    • Enterprise Developer Edition

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{60600409-EA9B-45E9-A468-2C68C8DE70DF}

    Visual Studio .NET 2002, all editions

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Registration\{005F0409-6759-11D5-A54F-0090278A1BB8}

  4. Start Visual Studio 2005 or Visual Studio .NET.
You see the behavior that is mentioned in the "Symptoms" section.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

306905 Visual IDE does not open when started or application cannot start error message


Modification Type:MajorLast Reviewed:2/27/2006
Keywords:kbvs2005applies kbvs2005swept kbide kbRegistry kbtshoot kbprb KB884463 kbAudDeveloper