FIX: You receive a "Microsoft Jet database error 8004005" error message when you try to upload an Office Excel worksheet in Commerce Server 2000 SP3 (883671)



The information in this article applies to:

  • Microsoft Commerce Server 2000 SP3

SYMPTOMS

When you try to upload a Microsoft Office Excel Worksheet in Microsoft Commerce Server 2000 Service Pack 3 (SP3), the file does not upload and you may receive an error message that is similar to the following:
Microsoft Jet database error 8004005 Unspecified error.
Typically, this problem occurs when you use code that is similar to the following to make a call to the Microsoft Jet driver:
SET OCONN=CreateObject ("adodb.connection") 
OCONN.Open "Provider=Microsoft.jet.OLEDB.4.0: DATASOURCE= "STEMP & FILENAME &" : 
Extended properties = excel 8.0 : imex = 1"

CAUSE

This problem occurs because the Csdwutil.dll process in Commerce Server 2000 SP3 creates a memory heap with 208 MB of reserved bytes. A fragmentation in memory may cause this problem to occur.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Commerce Server 2000 Service Pack 3 (SP 3)

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version    Size      File name
  -------------------------------------------------------
  13-Aug-2004  16:42  4.0.3868.0   53,520  Csdwdbgsrv.exe 
  13-Aug-2004  16:42  4.0.3868.0  454,928  Csdwutil.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, you must reset Microsoft Internet Information Services (IIS) by using the following command:

IISReset

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbCmcServ2000fix kbfix kbbug KB883671 kbAudDeveloper