Windows XP Setup program may stop responding during video driver installation (883667)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When an OEM performs a factory installation of an OEM version of Microsoft Windows XP, or when you use a Sysprep image to install Windows XP, the Setup program may stop responding during the video driver installation process.

CAUSE

This problem occurs because of a problem with the Video.inf file. If a driver is signed, but the driver does not include an .inf file that describes child devices, such as monitors, the installation may stop responding.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name    Service pack level
   ----------------------------------------------------------------------------
   12-Aug-2004  17:57  5.1.2600.1582     237,568  Newdev.dll   SP1QFE       
   12-Aug-2004  17:50  5.1.2600.2505     247,808  Newdev.dll   SP2QFE      


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

WORKAROUND

You may be able to work around this problem by restarting the computer.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbbug kbQFE kbHotfixServer KB883667 kbAudOEM