The Licensing Logging service cannot find the domain controller and you cannot manage licenses when the License Logging service starts on a Windows Server 2003-based computer (883645)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to use the License Logging service on a Microsoft Windows Server 2003-based computer, the following symptoms may occur when the License Logging service starts:
  • The License Logging service cannot find the domain controller.
  • You cannot manage licenses.

CAUSE

This behavior may occur when the License Logging service starts and then the Llssrv.exe process calls the DsGetDcName function. When this call occurs, the DsGetDcName function may return the following error message, based on the timing of the License Logging service status:
ERROR_NO_SUCH_DOMAIN
If the DsGetDcName function returns this error message, the Llssrv.exe process cannot find the domain controller, even if the Llssrv.exe process is running on the domain controller. Therefore, the Llssrv.exe process cannot find the master license server. A remote procedure call (RPC) exception occurs.

WORKAROUND

To work around this behavior, restart the License Logging service or do not use the License Logging service on a Windows Server 2003-based computer.

Note By default, the License Logging service is disabled in Windows Server 2003.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824196 Description of the License Logging Service in Windows Server operating systems


Modification Type:MajorLast Reviewed:11/8/2004
Keywords:kbprb kbtshoot KB883645 kbAudITPRO