E-mail messages that contain a virus remain in the SMTP local delivery queue after you configure Intelligent Message Filter in Exchange Server 2003 (883522)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

After you install and configure Microsoft Exchange Intelligent Message Filter on your Microsoft Exchange Server 2003 computer, e-mail messages that contain a computer virus or a worm program are not permanently deleted. Instead, these e-mail messages remain in the SMTP local delivery queue in Exchange 2003 until they time out.

Note These e-mail messages also remain in the following folder on the Exchange 2003 computer:

%PROGRAMFILES%\Exchsrvr\Mailroot\vsi 1\queue\

CAUSE

This problem occurs if the following conditions are true:
  • You have a Virus Scanning API (VSAPI) version 2.5-based virus scanning program installed.

    Note Virus Scanning API is also referred to as Virus API (VAPI) or Antivirus API (AVAPI).
  • You have Intelligent Message Filter installed.
In this scenario, the following behaviors occur:
  1. Exchange 2003 receives an e-mail message and directs this e-mail message to the intended recipient.
  2. The e-mail message is received by the Microsoft Exchange Information Store service and is scanned for viruses by the VSAPI version 2.5-based virus scanning program.
  3. If the e-mail message contains a virus or a worm program, VSAPI version 2.5 requests that the message be deleted.

    Note The option for an antivirus program vendor to configure their program to automatically delete e-mail messages is a new feature in VSAPI version 2.5.
  4. The e-mail message is deleted.
In this scenario, the message that was directed to the recipient is deleted because it contains a virus or a worm program. However, the original e-mail message remains in the SMTP local delivery queue until Exchange 2003 receives a notification of a successful message delivery. Exchange 2003 repeatedly retries delivering the e-mail message to the recipient. Each delivery attempt causes the scanned message to be deleted by VSAPI version 2.5.

RESOLUTION

Update information

The following file is available for download from the Microsoft Download Center:

DownloadDownload the Exchange2003-KB883522-v2-x86-ENU.exe package now.

Release Date: December 3, 2004

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Prerequisites

Because of file dependencies, you must be running Microsoft Exchange Server 2003 Service Pack 1 (SP1) to install this update. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you install this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------   
   20-Sep-2004  10:27  6.5.7232.36       395,264  Exsmtp.dll       
   20-Sep-2004  09:18  6.5.7232.36     3,230,720  Mdbmsg.dll       
   20-Sep-2004  09:34  6.5.7232.36     5,139,456  Store.exe        
To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbBug kbExchange2003preSP1fix KB883522 kbAudITPRO