You receive an "Access is denied" error message when you connect to a Web site after you modify permissions in the metabase in IIS 6.0 (883489)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to connect to a Web site by using a Web browser, you receive the following error message:
Access is denied
You receive this message when you modify permissions in the Microsoft Internet Information Services (IIS) 6.0 metabase so that the application pool that is configured for the root Web site does not have permissions to access Web applications that are configured in subfolders of the root Web site.

CAUSE

This problem occurs because the metabase cache is not created correctly if the worker process that is configured for the root Web site does not have permissions to access Web applications that are configured in subfolders of the Web site.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

If you stop IIS before you install the hotfix, you do not have to restart your computer after you apply the hotfix.

If you do not stop IIS before you install the hotfix, you have to restart your computer after you apply the hotfix.

Note To stop IIS, click Start, click Run, type iisreset /stop in the Open box, and then click OK. To start IIS after you stop it, click Start, click Run, type iisreset /start in the Open box, and then click OK.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version       Size     File name
-----------------------------------------------------
11-Aug-2004  00:33  6.0.3790.198  342,528  W3core.dll

Windows Server 2003 64-bit edition

Date         Time   Version       Size     File name   Platform
---------------------------------------------------------------
10-Aug-2004  23:51  6.0.3790.198  950,784  W3core.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbfix kbBug kbWinServ2003preSP1fix kbHotfixServer kbQFE KB883489 kbAudITPRO