You receive a "Control ID not found" error message when you try to install Windows XP Service Pack 2 or Windows XP Tablet PC Edition 2005 (878472)



The information in this article applies to:

  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Tablet PC Edition 2005

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

SYMPTOMS

When you try to install Microsoft Windows XP Service Pack 2 (SP2) or Microsoft Windows XP Tablet PC Edition 2005, you receive the following error message:
Service Pack 2 Setup Error

Control ID not found
After you click OK, you receive the following message:
Service Pack 2 Setup Error

Service Pack 2 installation did not complete.
The Svcpack.log file may contain entries that are similar to the following:

1131.076: MyFCIFlushCabinet() failed: code 4 [Could not create a temporary file]
1132.057: Cabinet build used 28711 ticks
1132.057: Cabinet build failed, GLE=0x0000058D
1132.057: CabinetBuild: BuildCabinet Function failed
1132.057: DoInstallation:CabinetBuild failed
1149.593: Control ID not found.
3805.201: Message displayed to the user: Control ID not found.
3805.201: User Input: OK
3805.231: Service Pack 2 installation did not complete.
3817.379: Message displayed to the user: Service Pack 2 installation did not complete.
3817.379: User Input: OK
3817.379: Update.exe extended error code = 0x58d
3817.379: Update.exe return code was masked to 0x643 for MSI custom action compliance.

CAUSE

This problem may occur if the eTrust antivirus program is running when you try to install Windows XP SP2. When the Setup program tries to open a .cab file, the eTrust antivirus program puts a file lock on the .cab file to scan the file for viruses. The Setup program, Update.exe, detects the file lock and logs the error.

RESOLUTION

To resolve this problem, contact Computer Associates for information about an update to the eTrust antivirus program. This problem was first corrected in the eTrust version that is dated April 10, 2004

For information about how to contact Computer Associates, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

WORKAROUND

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

To work around this problem, temporarily stop the eTrust Realtime Monitor program, and then install Windows XP SP2. To do this, follow these steps:
  1. Download the Windows XP SP2 installation file and save the file to a local folder.
  2. To temporarily stop the eTrust Realtime Monitor, right-click the Realtime Monitor icon in the notification area, and then click Disable Realtime.
  3. To install the service pack, double-click the Windows XP SP2 installation file.
  4. After the service pack installation is completed, turn on the eTrust Realtime Monitor:
    • Right-click the Realtime Monitor icon in the notification area, and then click Monitor Outgoing and Incoming Files.
Note An antivirus program is designed to help protect your computer from viruses. While your antivirus program is disabled, you must not download or open files from sources that you do not trust, you must not visit Web sites that you do not trust, and you must not open e-mail attachments.

For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:

129972 Computer viruses: description, prevention, and recovery



The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbtshoot kbvirus kbClient kberrmsg kbUpgrade kbsetup kbinterop kbSecurity kbprb kbnofix kbBug KB878472 kbAudEndUser kbAudITPRO