You may receive a "The network name cannot be found" error message when you use the fully qualified domain name to connect to a remote computer from a Windows Server 2003-based, Windows XP-based or Windows 2000-based computer (875441)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium) 2003
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use the net use command on a computer that is running one of the operating systems that is listed in the "Applies to" section to access the shared resources of a remote computer, you may receive the following error message if you use the fully qualified domain name (FQDN) of the remote computer:
System error 67 has occurred

The network name cannot be found
When you use the Open box of the Run dialog box to connect to the remote computer, you may receive the following error message if you use the FQDN of the remote computer:

No network provider accepted the given network path
Note You may be able to ping the remote computer by using the FQDN of the remote computer. No entries may be recorded in the Domain Name System (DNS) cache or in the NetBIOS over TCP/IP (NetBT) cache when you try to connect to the remote computer.

CAUSE

When the name resolution request for FQDN is queued inside NetBT, the request times out, the redirector closes the connection after about eight seconds, and the FQDN name is not resolved. The issue occurs because of contention for the NetBT user mode DNS resolver. This resolver can only resolve names serially.

WORKAROUND

To resolve this issue, use one of the following methods.

Method 1: Increase the value of the LmhostsTimeout registry entry

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

You can increase the value of the LmhostsTimeout registry entry to increase the timeout interval of NetBT queries to the Lmhosts file and to DNS. You can use this method to give more time for NetBT queries to resolve the FQDN of the remote computer.

To modify the value of the LmhostsTimeout registry entry, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters

  3. In the right pane, double-click LmhostsTimeout, type a value that is larger than the current value in the Value data box, and then click OK.

    Note If you do not find the LmhostsTimeout registry entry in Registry Editor, create a new registry entry. To do this, follow these steps:
    1. In the left pane, right-click the Parameters subkey, point to New, and then click DWORD Value.
    2. Type LmhostsTimeout and then press ENTER.
    3. Double-click LmhostsTimeout, click Decimal, and then type a time in milliseconds between 1000 and 4294967295 in the Value data box. Click OK.

      Note The valid hexadecimal base range for the LmhostsTimeout entry is 3E8 to 0xFFFFFFFF.
  4. Quit Registry Editor.
  5. Restart your computer.

Method 2: Install Internet Protocol version 6 (IPv6) on the local computer

Note You can use this method only if the following conditions are true:
  • The local computer is running Microsoft Windows Server 2003 or Microsoft Windows XP.
  • The remote computer that you connect to is running Windows Server 2003, Windows XP or Microsoft Windows 2000.
  1. Click Start, click Run, type ncpa.cpl, and then click OK.
  2. Right-click the local area connection that you want to modify, and then click Properties.
  3. Click Install.
  4. In the Click the type of network component you want to install list, click Protocol, and then click Add.
  5. Click Microsoft TCP/IP version 6, and then click OK.
  6. Click Close to save the changes that you made to your network connection.

MORE INFORMATION

For more information about how to configure IPv6 in Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:

325449 How to install and configure IP version 6 in Windows Server 2003 Enterprise Server

LmhostsTimeout registry entry details

Entry name: LmhostsTimeout
Subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters
Value type: REG_DWORD (Time in milliseconds)
Valid range: Decimal: 1000 to 4294967295 (Hexadecimal: 3E8-0xFFFFFFFF)
Default: 6000 (6 seconds)
Description: This parameter specifies the time-out value for NetBT queries to the Lmhosts file and to DNS. The timer has a granularity of the time-out value. Therefore, the actual time-out could be as much as two times the value.

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:7/22/2005
Keywords:kbwinservnetwork kbnetwork kbtshoot KB875441 kbAudITPRO