Remote Desktop Web Connection triggers an access violation and does not respond when you set the FilterQueueType registry value to 0x7 in Windows Server 2003 (873391)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to run Remote Desktop Web Connection (Msrdp.ocx), an access violation occurs, and Remote Desktop Web Connection does not respond. This symptom occurs if either of the following conditions is true:
  • You installed Remote Desktop Web Connection from the Microsoft Windows Server 2003 CD-ROM by using the Add or Remove Programs tool in Control Panel. You have then set the FilterQueueType registry value to 0x7.
  • You downloaded Remote Desktop Web Connection from the Windows Server 2003 Web site and set the FilterQueueType registry value to 0x7.

CAUSE

This issue occurs if the network port name for the printer contains a null value. Even though a null value is valid for the network port name, Remote Desktop Web Connection does not correctly handle this condition.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   29-Jul-2004  09:13  6.0.2600.0        498,688  Tswebsetup.exe   

WORKAROUND

To work around this problem, do not use the FilterQueueType registry entry.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE KB873391 kbAudITPRO