A tape device unexpectedly goes offline and backup operations that use third-party backup software are not completed successfully in Windows Server 2003 (873337)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems


Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You are using a tape device with a medium changer device and with third-party backup software on your Microsoft Windows Server 2003-based computer. Sometimes, Windows Server 2003 cannot control the medium changer device. The tape device unexpectedly goes offline, and backup operations are not completed successfully. You have to restart your computer to reset and restore connectivity to the medium changer device and to the tape device.

CAUSE

This issue occurs if the third-party backup software is not fully compliant with the Plug and Play feature in Windows Server 2003. When the medium changer and tape devices lose connectivity, the Plug and Play feature in Windows Server 2003 creates new names for the devices. The third-party software processes the names of the devices when the computer restarts. The third-party software does not recognize the new names, and the devices do not work as expected.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
Date         Time   Version        Size    File name
----------------------------------------------------
21-Oct-2004  15:51  5.2.3790.224   15,360  Mcd.sys
21-Oct-2004  15:51  5.2.3790.224   20,480  Tape.sys
 
Windows Server 2003, 64-bit edition
Date         Time   Version       Size    File name
---------------------------------------------------
21-Oct-2004  16:51  5.2.3790.224  38,400  Mcd.sys
21-Oct-2004  16:51  5.2.3790.224  55,808  Tape.sys

Add the Persistence registry entry after you install the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix after you install it, add the Persistence registry entry to the following registry subkey, and then set the registry entry to 1:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Tape

When you set the Persistence registry entry to 1, symbolic names that are used by the Plug and Play feature in Windows Server 2003 are persistent. If you set the Persistence registry entry to 0 (zero), or if you remove the Persistence registry entry, symbolic names are not persistent.

To enable the hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Tape

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type Persistence, and then press ENTER.
  5. Right-click the Persistence registry entry, and then click Modify.
  6. Type 1 in the Value data box, and then click OK.
  7. Quit Registry Editor.
  8. Restart the computer.

WORKAROUND

To work around this issue, restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Note This fix requires that Tape.sys be in use as the tape class device driver. This fix will have no effect if your backup solution uses a third-party tape class driver.

For more information about how to resolve this issue in Microsoft Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

889330 A tape device unexpectedly goes offline, and backup operations using third-party backup software are not completed successfully in Windows 2000

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB873337 kbAudEndUser kbAudITPRO