A 32-bit third-party service quits unexpectedly on a Windows Server 2003 64-bit edition-based computer (872768)



The information in this article applies to:

  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition

SYMPTOMS

A third-party service may quit unexpectedly on a Microsoft Windows Server 2003 64-bit edition-based computer when the following conditions are true:
  • The third-party service runs as a 32-bit process.
  • The third-party service calls either the GetFileType function or the GetStdHandle function.

CAUSE

This problem occurs because the process environment block (PEB) of the 32-bit process has become corrupted. This corruption causes the service to return FILE_TYPE_UNKNOWN to Microsoft Windows on the 64-bit operating system. Windows on 64-bit operating systems is a 32-bit Windows subsystem that you can use to run 32-bit programs on 64-bit versions of Windows.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   01-Jul-2004  17:22  5.2.3790.186      449,536  Wow64.dll        IA-64
   01-Jul-2004  17:22  5.2.3790.186      527,360  Wow64win.dll     IA-64
   21-Apr-2004  16:35                        271  Branches.inf
   01-Jul-2004  17:56                     10,119  Kb872768.cat
   01-Jul-2004  17:29                        354  Updatebr.inf
   01-Jul-2004  17:29                      5,762  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB872768 kbAudITPRO kbAudDeveloper