"Installation failed: Access is denied" error message when you try to perform a remote installation of Computer Associates eTrust Antivirus 7.0 client software on a computer that is running Windows XP Service Pack 2 (870901)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to use the Computer Associates eTrust Antivirus Remote Install utility to install the eTrust Antivirus 7.0 client on a computer that is running Microsoft Windows XP Service Pack 2 (SP2), the installation does not succeed. When you click Install to Targets, you receive the following error message:
Installation failed: Access is denied. (5)

CAUSE

This behavior occurs because of changes to the Remote Procedure Call service in Windows XP SP2. By default, the RestrictRemoteClients registry entry is turned on in Windows XP SP2. This registry entry restricts access to all remote procedure call interfaces.

WORKAROUND

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this behavior, install the eTrust Antivirus client locally. If you cannot install the eTrust Antivirus client locally, you can modify the registry to turn off the RestrictRemoteClients registry entry. To do this, follow these steps.

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\RPC

    If this subkey does not exist, follow these steps:
    1. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT

    2. On the Edit menu, point to New, and then click Key.
    3. Type RPC as the subkey name, and then press ENTER.
    4. Right-click RPC, point to New, and then click DWORD Value.
    5. Type RestrictRemoteClients as the entry name, and then press ENTER.
  3. Right-click the RestrictRemoteClients entry, and then click Modify.
  4. In the Value Data box, type 0 (zero), and then click OK.
  5. Quit Registry Editor.
  6. Restart your computer.
If you modify the registry, we recommend that you turn the RestrictRemoteClients registry entry back on after you install the eTrust Antivirus 7.0 client. To turn the RestrictRemoteClients registry entry back on, set the value to 1 or to 2, and then restart your computer. By default, the value of the RestrictRemoteClients registry entry is 1 in Windows XP SP2.

MORE INFORMATION

For information about how to contact Computer Associates, visit the following Computer Associates Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

For additional information about the RPC Interface Restriction feature in Windows XP SP2, and also for a description of the RestrictRemoteClients registry entry and its possible values, visit the following Microsoft Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbRemoting kbvirus kbconnectivity kbnetwork kb3rdparty kbtshoot kbprb kberrmsg KB870901 kbAudITPRO