USB device does not function after connecting device to a Windows XP Service Pack 2-based computer or to a Windows XP Tablet PC Edition 2005-based computer (870893)



The information in this article applies to:

  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005

SYMPTOMS

When you plug a USB device into a powered USB hub or into the USB port on your computer, the device may not be available for use or may not receive power. You may not receive a "USB Hub Power Exceeded" error message.

CAUSE

This problem may occur if you plug in a high-power USB device such as a USB hard disk, and the USB device consumes more than 500 milli-amps (mA) power in a computer that supports either Intel ICH5 or ICH6 (I/O Controller Hub) system. Some ICH5 or ICH6 systems do not verify over-current situations and do not generate any "USB Hub Power Exceeded" error messages.

WORKAROUND

To work around this issue, you must power the USB device by an external power source if one is available for the device. For example, you may be able to use an AC adapter to power the USB device.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:11/15/2004
Keywords:kbUSB kbnofix kbprb KB870893 kbAudEndUser kbAudITPRO