The Exchange 2000 Instant Messaging service occasionally stops responding and a Dr. Watson error is generated for the Inetinfo.exe process in Exchange 2000 Server (870811)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

The Microsoft Exchange 2000 Server Instant Messaging service may occasionally stop responding (hang) and may generate a Dr. Watson crash dump file for the Inetinfo.exe process.

CAUSE

This problem occurs because of a synchronization problem in the Exchange Instant Messaging component. This synchronization problem may cause the socket list to become corrupted and the Instant Messaging service to stop responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   -------------------------------------------------------
   23-Jun-2004  04:00  6.0.6604.0      61,440  Msimcfg.dll
   23-Jun-2004  04:02  6.0.6604.0     167,936  Msimmsg.dll
   23-Jun-2004  04:02  6.0.6604.0     319,488  Msimsrv.dll

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbQFE kbHotfixServer kbfix kbExchange2000preSP4fix kbbug KB870811 kbAudITPRO