FIX: A SQL Server CE connectivity application stops responding when a network connection that connects a Windows CE-based device to a network is disconnected (870810)



The information in this article applies to:

  • Microsoft SQL Server 2000 Windows CE Edition 2.0

Bug #: 8388 (SSCE)
SSCE:8388

SYMPTOMS

When a network connection that connects a Microsoft Windows CE-based device to a network is disconnected, a Microsoft SQL Server 2000 Windows CE Edition 2.0 connectivity application that is running on the Windows CE-based device may stop responding. The SQL Server CE 2.0 connectivity application returns no error messages.

Note The connectivity application may be a replication application or a Remote Data Access (RDA) application.

CAUSE

This problem occurs because the Windows CE-based device may experience many periodic failures when communicating through a network. To work around these periodic failures, the SQL Server CE connectivity component is designed to retry network connections. Therefore, even though the network is disconnected while a replication method call or an RDA method call is made, you may not receive an error message, and the connectivity application stops responding.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name           Platform
   ------------------------------------------------------------------------------
   10-Feb-2004  10:07  2.0.6210.0      1,377,792  Ssce20.dll          ARM
   10-Mar-2004  06:17  2.0.6310.0        264,192  Ssceca20.dll        ARM
   15-Aug-2002  18:54  2.0.4415.0         70,144  Ssceerror20en.dll   ARM
   22-Mar-2004  06:45  2.0.6310.0        994,816  Ssce20.dll          I386
   22-Mar-2004  06:47  2.0.6310.0        200,192  Ssceca20.dll        I386
   07-May-2004  15:20  2.0.6507.0        221,250  Sscesa20.dll
				
Note Because of file dependencies, the most recent hotfix or feature that contains the files in this table may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Apply the hotfix

  1. On the Windows CE-based device, replace the following SQL Server CE files with the corresponding files that are included in this hotfix:
    • Ssce20.dll (SQL Server CE Engine)
    • Ssceca20.dll (SQL Server CE Client Agent)
    Notes
    • When you deploy your SQL Server CE 2.0 connectivity application from Visual Studio .NET, the SQL Server CE files are installed in the "Program Files\SQLCE 2.0" path.
    • When you deploy your SQL Server CE 2.0 connectivity application from Microsoft eMbedded Visual Tools, the SQL Server CE files are installed in the "\Windows" path.
    • When you develop an application in a mixed environment that contains Visual Studio .NET and eMbedded Visual Tools, you must replace the files in both paths. You can replace the files in the path where the application was last deployed.
  2. On the computer that is running Microsoft Internet Information Services (IIS), replace the Sscesa20.dll (SQL Server CE Server Agent) file on the appropriate virtual directory.
  3. Perform a soft reset of the Windows CE-based device.
  4. Restart IIS on the computer that is running IIS. To do this, run the iisreset command at a command prompt.

REFERENCES

For additional information about a related network connectivity problem in SQL Server CE 1.x, click the following article number to view the article in the Microsoft Knowledge Base:

285865 PRB: SQL Server CE connectivity application stops responding when network connection is dropped


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbnetwork kbVSNET2003sp1fix kbfix kbbug KB870810 kbAudDeveloper