You receive the "Access is denied" error message when you run a 16-bit program on Windows 2000 SP3 or on Windows 2000 SP4 (867787)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4

SYMPTOMS

When you try to run a 16-bit MS-DOS-based program, you may receive the following error message:
NTVDM has encountered a System Error.
Access is denied.
Choose 'Close' to terminate the application.
For example, you try to run the Command.com program or the Edit.exe program.

CAUSE

This problem occurs because a regression may occur in the Microsoft Windows NT virtual DOS machine (NTVDM) subsystem after you apply an earlier hotfix. For additional information about this earlier hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

324446 Terminal Server and connected Terminal Services clients pause when a Terminal Services client logs on or logs off

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   --------------------------------------------------------------
   10-Feb-2004  19:47  5.0.2195.6897      30,160  Mountmgr.sys
   17-Jun-2004  18:20  5.0.2195.6942   1,704,128  Ntkrnlmp.exe     
   17-Jun-2004  18:20  5.0.2195.6942   1,703,744  Ntkrnlpa.exe     
   17-Jun-2004  18:20  5.0.2195.6942   1,725,440  Ntkrpamp.exe     
   17-Jun-2004  18:19  5.0.2195.6942   1,680,832  Ntoskrnl.exe     
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named and about other terms for software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB867787 kbAudITPRO kbAudEndUser