BUG: An error may occur when you try to open signed solutions by using the Open method in Office InfoPath 2003 Service Pack 1 (867441)



The information in this article applies to:

  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)

SYMPTOMS

You can open signed solutions from the user interface (UI) in Microsoft Office InfoPath 2003 Service Pack 1. However, if you try to open signed solutions by using the Open method of the object model (OM), you may receive the following error message:
InfoPath cannot load this form.
The signature on this form is not from a trusted publisher.

CAUSE

This problem occurs if all the following conditions are true:
  • The signed certificate comes from an un-trusted root.
  • The signed certificate is in your Trusted Publishers list.
  • You have a private key for the signed certificate.
This problem may occur when you create a test certificate for development purposes.

WORKAROUND

To work around this problem, follow these steps:
  1. Click Start, click Run, and then type mmc in the Run dialog box.
  2. On the File menu, click Add/Remove Snap-In.
  3. Click Add.
  4. Click Certificates, and then click Add.
  5. Click My user account, and then click Finish.
  6. Click Close, and then click OK.
  7. Expand the Certificates - Current User node in Microsoft Management Console.
  8. Right-click the Trusted Root Certification Authorities folder.
  9. On the All Tasks menu, click Import.
  10. Follow the steps in the Certificate Import Wizard to import the test certificate to the Trusted Root Certification Authorities group.

    Warning Be careful when you add certificates to this group. You do not want to accidentally trust a third-party certificate.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, visit the following Microsoft Developer Network (MSDN) Web sites:

AuthenticodeUnderstanding fully trusted forms

Modification Type:MajorLast Reviewed:8/5/2004
Keywords:kbtshoot kbbug KB867441 kbAudDeveloper kbAudITPRO