"An invalid directory pathname was passed" error message when you use Active Directory Users and Computers to view user properties in Windows Server 2003 (842632)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

In Microsoft Windows Server 2003, you can use the Active Directory Users and Computers snap-in to view the properties of a user. However, when you click the Members tab in the Properties dialog box for a particular user, you receive an error message that is similar to the following:
An invalid directory pathname was passed.

CAUSE

This problem may occur if the all the following conditions are true:
  • The user is a member of a group that has a forward slash character (/) in the group name.
  • You install the hotfix that is described in the following Microsoft Knowledge Base (KB) article:

    833883 You cannot view a user's Universal Group membership in Windows Server 2003 Active Directory Users and Computers when Universal Groups do not reside in the local domain

  • You edit the AlwaysShowExternalGroups subkey as directed in KB article 833883.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date 		Time 	Version 	Size 	  File name
------------------------------------------------------------ 
10-Jun-2004	17:09 	5.2.3790.182 	760,320   Adprop.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB842632 kbAudITPRO