Automatic updates may not be successfully downloaded from a computer that is running Software Update Services (842289)



The information in this article applies to:

  • Microsoft Software Update Services, version 1.0

SYMPTOMS

When a client computer tries to download automatic updates across a slow network connection from a computer that is running Microsoft Software Update Services (SUS), the automatic updates may not successfully download.

Additionally, you may receive the following error message in the Windows Update log on the client computer:
Error 0x80004005: Unspecified error

CAUSE

This problem may occur if the client computer resets the connection to the server before the server has sent all the data to the client during automatic update detection.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Software Update Services Service Pack 1

Restart requirement

You may have to restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size        File name
   -------------------------------------------------------------------
   23-Jul-2004  19:05  6.0.2600.0  35,961,112  Sus1.0-kb842289-enu.exe
To install this hotfix, type the following command at a command prompt, and then press ENTER:

msiexec /p Full path of FixBinary.msp reinstall=all /qb

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When the fix is installed on an SUS server, the clients receive the updates when they connect to the SUS server. This is known as self update and uses the Winhttp.dll file. This process does not involve the 30-second timeout limitation. When the server is updated, the clients will replace existing binaries on their computers with the new binaries, including the new Iuengine.dll (fixed binary). Iuengine.dll no longer has the 30-second timeout limitation. This binary, Iuengine.dll, is used for Microsoft Windows 2000, Windows XP, and Windows Server 2003, so if the SUS server is patched, all clients should be updated with Iuengine.dll version 5.4.3790.21. The fix is also included in Windows XP Service Pack 2.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix KB842289 kbAudITPRO