Event ID 9646 is logged in the application event log of your Exchange Server 2003 computer when a client opens many MAPI sessions (842022)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

On your Microsoft Exchange Server 2003 computer, an error event that is similar to the following is logged in the application event log:Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9646
Description:
Closing Mapi session "/o=Organization/ou=Administrative Group/cn=Recipients/cn=Recipient" because it exceeded the maximum of 32 objects of type "session". When this behavior occurs, you may also receive the following error message in Microsoft Office Outlook 2003.
Unable to open your default e-mail folders. The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server is down for maintenance.

CAUSE

This behavior may occur if both the following conditions are true:
  • You have installed Exchange Server 2003 Service Pack 1 (SP1) on your Exchange Server computer.
  • A program that is running on a client computer opens many MAPI sessions to the Exchange Server computer. The number of MAPI sessions is greater than the permitted limit.
Exchange Server 2003 SP1 imposes a restriction on the number of permitted MAPI sessions per user. By default, the maximum number of permitted MAPI sessions per user is set to a hexadecimal value of 0x20 after you apply Exchange Server 2003 SP1.

Note A hexadecimal value of 0x20 converts to a decimal value of 32.

RESOLUTION

To resolve this behavior, we recommend that you first investigate if the MAPI session limit is reached because of potential abuse, because it is the result of a bug in a client program, or because of client program design.

If the behavior is triggered by a bug in a client program or by a client program design, we recommend that you contact the vendor to determine if you can do either of the following:
  • Obtain a fix.
  • Grant the View Information Store Status Exchange permission to the account that the program runs under. Programs that run under an account that has this permission are not affected by the MAPI sessions per user limit. To grant the View Information Store Status permission, follow these steps:
    1. In Exchange System Manager, right-click the Exchange Server object or the mailbox store that you want to grant the permission to, and then click Properties.
    2. Click the Security tab.
    3. Click the account that you want to grant the permission to.

      If the account is not listed, click Add, click the account name, click Add, and then click OK.
    4. Under the Allow column, click to select the View information store status check box if it is not already selected.
    5. Click to clear the check boxes for any permissions that are not required, and then click OK. You may have to perform this step because if you clicked Add to add the account in step c, every check box in the Allow column is selected.
If you cannot obtain a fix and you cannot configure the account to run with the View Information Store Status permission, you can adjust the number of permitted MAPI sessions per user in the registry. If you raise the MAPI session limit, try to determine the minimum value that you can use so that the client program can run without problems. If you raise the limit too high, the client program can potentially affect the performance of the Exchange Server computer.

MORE INFORMATION

To change the value of the maximum permitted MAPI sessions per user from the default, you can configure the Maximum Allowed Sessions Per User registry entry. To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate, and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. If the Maximum Allowed Sessions Per User entry does not exist, do the following:
    1. On the Edit menu, point to New, and then click DWORD Value.
    2. Type Maximum Allowed Sessions Per User as the entry name, and then press ENTER.
  4. Right-click the Maximum Allowed Sessions Per User entry, and then click Modify.
  5. Click Decimal, type the value that you want to set in the Value data box, and then click OK.
  6. Quit Registry Editor.

Modification Type:MajorLast Reviewed:8/30/2006
Keywords:kbprb KB842022 kbAudITPRO