You may receive a "machine cannot be found" error message when you try to access remote processes in Visual Studio 2005 or in Visual Studio .NET (840927)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition

SYMPTOMS

In Microsoft Visual Studio 2005 or in Microsoft Visual Studio .NET, when you try to access processes that are running on a remote computer, you may receive the following error message:
Unable to connect to the machine computername. The machine cannot be found on the network.
Note In this error message, computername is a placeholder for the name or for the IP address of the remote computer that you are trying to connect to.

CAUSE

This behavior occurs if one of the following conditions is true:
  • Your connection to the remote computer was broken.
  • Your user account on the remote computer is disabled.
  • Your password on the remote computer has expired.

RESOLUTION

To resolve this behavior, use one of the following methods:
  • Make sure that the local computer and the remote computer are in the same network. To do this, use Microsoft Windows Explorer to try to access the remote computer.
  • Make sure that the user account that you are using to connect to the remote computer is enabled.
  • Make sure that the password that you are using to connect to the remote computer is valid and has not expired.

MORE INFORMATION

Steps to reproduce the behavior

  1. Create a user account that has the same user name and password combination on the local computer and on the remote computer.
  2. Make the user account a member of the Debugger Users group both on the local computer and on the remote computer.
  3. Disable the user account on the remote computer.
  4. Log on to the local computer by using the user account that you created in step 1.
  5. Start Visual Studio 2005 or Visual Studio .NET.
  6. On the Tools menu, click Debug Processes. The Processes dialog box appears.
  7. In the Name box, type the IP address of the remote computer, and then click Refresh.

STATUS

This behavior is by design.

REFERENCES

For more information about debugging and about troubleshooting remote debugging problems, visit the following Microsoft Developer Network (MSDN) Web sites:

Modification Type:MajorLast Reviewed:3/3/2006
Keywords:kbvs2005swept kbvs2005applies kbAAcc kbUser kbconnectivity kbprb KB840927 kbAudDeveloper