A NULL IP address is assigned to the network adapter in a Windows Server 2003-based computer (840711)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

In some scenarios, a network adapter in a Microsoft Windows Server 2003-based computer that has been assigned a valid static IP address may be assigned a NULL IP address (0.0.0.0).

CAUSE

This problem occurs because of a race condition in TCP/IP.

Specifically, this problem may occur if both of the following conditions are true:
  • TCP/IP initializes faster than the network becomes ready.
  • Another component programmatically disables the Media Sensing feature in Windows Server 2003.
For example, Cluster Services (Clusnet.sys) may disable Media Sensing. User-mode applications may also disable Media Sensing by calling the IP Helper DisableMediaSense function.

This problem may also occur if you are using a Gigabit network adapter, because this network adapter may take longer to negotiate with the switch. This problem is even more likely to occur if multiple network adapters are tied together by a load-balancing failover NDIS MUX driver. In this scenario, the speed of the network initialization process may decrease significantly.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Apr-2004  22:37  5.2.3790.163      334,336  Tcpip.sys
   12-Apr-2004  22:56                        271  Branches.inf
   13-Apr-2004  23:51                      9,766  Kb840711.cat
   13-Apr-2004  23:45                        354  Updatebr.inf
   13-Apr-2004  23:45                      5,694  Update_rtmqfe.inf

Windows Server 2003 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Apr-2004  22:37  5.2.3790.163      971,776  Tcpip.sys
   12-Apr-2004  22:56                        271  Branches.inf
   13-Apr-2004  23:51                      9,766  Kb840711.cat
   13-Apr-2004  23:47                        354  Updatebr.inf
   13-Apr-2004  23:47                      5,714  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB840711