You receive an "ADDRESS_IN_USE" error message when you restart the firewall service in Microsoft Internet Security and Acceleration Server 2004 (840618)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you restart the firewall service in Microsoft Internet Security and Acceleration Server 2004, you may receive the following error message:
ADDRESS_IN_USE
Note You may also be warned to restart firewall services in the ISA Server Management console.

CAUSE

This issue may occur after you restart the firewall service and there is continuous Web traffic passing through the ISA Server. When you restart the firewall service under this condition, the Web listener service that monitors traffic on port 8080 may not start and you may receive error message that is mentioned in the "Symptoms" section.

Additionally, when this condition occurs, any Web proxy clients that make a request over port 8080 will not be able to connect to the ISA Server.

WORKAROUND

To work around this issue, use the following methods.

Method 1

By default, when this issue occurs, it will persist for five minutes. This is the time the ISA server is set to wait for firewall services to start.

When this issue occurs, stop the firewall service, wait for five minutes, and then restart the firewall service.

Method 2

You can reduce the time the ISA Server waits before releasing connections that are in the close-Wait state by creating the following registry DWORD values in the registry of the ISA Server computer:
  • TcpTimedWaitDelay (DWORD)
  • StrictTimeWaitSeqCheck (DWORD)
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To create the DWORD values, follow these steps.

Create the TcpTimedWaitDelay DWORD value

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. In Registry Editor, locate the following subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Right-click Parameters, point to New, and then click DWORD Value.
  4. In the right pane, rename New Value as TcpTimedWaitDelay, and then press ENTER.
  5. In the right pane, right-click TcpTimedWaitDelay, and then click Modify.
  6. In the Value data text box, type the value to use seconds instead of minutes, and then click OK.

Create the StrictTimeWaitSeqCheck DWORD value

  1. Right-click Parameters, point to New, and then click DWORD Value.
  2. In the right pane, rename New Value as StrictTimeWaitSeqCheck, and then press ENTER.
  3. In the Value data text box, type 1 as the value to use, and then click OK.
  4. Quit Registry Editor, and then restart the computer.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:3/9/2006
Keywords:kbpending kbbug KB840618 kbAudDeveloper kbAudEndUser