Cannot access the Virtual Server Administration Website page in Virtual Server 2005 after you install the IIS Lockdown tool (840191)



The information in this article applies to:

  • Microsoft Virtual Server 2005

SYMPTOMS

When you try to access the Virtual Server Administration Website on a host computer that has the URLScan tool installed and is running Microsoft Virtual Server 2005, you may receive the following error message:
The page cannot be found

HTTP 404 - File not found

CAUSE

This issue may occur if you install the URLScan tool when you install the IIS Lockdown tool on your computer. By default, the URLScan tool blocks access to .exe files in Microsoft Internet Explorer. The URLScan tool is an optional component that may be installed when you install the IIS Lockdown tool.

RESOLUTION

To resolve this issue, disable the ability of URLScan to deny .exe files that could run on the server. To do this, follow these steps:
  1. In a text editor such as Notepad, open the Urlscan.ini file.

    Note The Urlscan.ini file is located in the C:\WINDOWS\system32\inetsrv\urlscan folder.
  2. Locate the Deny executables that could run on this server section.
  3. Insert a semicolon (;) at the beginning of the line that contains .exe.
  4. Save the Urlscan.ini file.
  5. Restart the IIS Admin service. To do this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. In the Name list, right-click IIS Admin, and then click Restart.
  6. Open the Virtual Server Administration Website.

MORE INFORMATION

For more information about the IIS Lockdown tool, visit the following Microsoft Web site: For more information about the URLScan tool, visit the following Microsoft Web sites:


Modification Type:MinorLast Reviewed:11/16/2004
Keywords:kbfix kberrmsg kbprb KB840191 kbAudITPRO