A Windows XP-based computer sends many ARP broadcast requests when the ARP cache entry for the peer expires during a large file transfer (840164)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

A Microsoft Windows XP-based computer may send many Address Resolution Protocol (ARP) broadcast requests when the ARP cache entry for the peer expires during a large file transfer.

CAUSE

This problem typically occurs when the Windows XP-based computer has a firewall program installed that blocks ARP replies. For example, if you communicate or if you copy files between a Windows XP-based computer and a destination computer and you turn on the ARP blocking feature, the Windows XP-based computer submits an ARP request to the destination computer when the ARP cache expires on the Windows XP-based computer. In this scenario, the ARP reply from the destination computer is blocked by the firewall. Therefore, Windows XP begins to broadcast many ARP requests.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP 32-bit version
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   25-May-2004  00:48  5.1.2600.1535     323,072  Tcpip.sys
Windows XP 64-bit version
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   25-May-2004  00:52  5.1.2600.1535   1,106,688  Tcpip.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

This problem may also occur on Microsoft Windows 2000-based computers and on Microsoft Windows Server 2003-based computers.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbtshoot kbWinXPpreSP2fix kbfix kbbug KB840164 kbAudITPRO