You cannot manage public queues that are created in a Windows NT 4.0 domain from a Windows XP computer (840146)



The information in this article applies to:

  • Microsoft Message Queuing 3.0, when used with:
    • the operating system: Microsoft Windows XP


Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You cannot manage public queues that you create by using a Microsoft Windows NT 4.0 user account in a Microsoft Windows 2000 domain. A problem may occur when you log on to Microsoft Windows XP by using the Windows NT 4.0 user account, and then you try to access the public queues.

CAUSE

By default, Message Queuing 1.0 clients and Message Queuing 2.0 clients use the remote procedure call (RPC) technology to access the Active Directory server or to access the Message Queue Information Store (MQIS) database. Access is made through the Message Queuing service that runs on a Windows 2000 domain controller or on a Windows NT 4.0 MQIS server. Each client keeps a list of Active Directory servers that run the Message Queuing service and calls one of the servers by using RPC. The Message Queuing service on the domain controller that is the Active Directory server listens to RPC, receives the call, and then processes the call.

In the Message Queuing 3.0 service, this default behavior changes, and the Message Queuing client uses the Active Directory Service Interfaces (ADSI) to access the Active Directory service directly without using any Message Queuing agent on the domain controller. By default, ADSI tries to access an Active Directory server in the domain of the user. All ADSI calls fail if the current logged-on user makes calls from a trusted Windows NT 4.0 domain. This problem occurs because the Windows NT 4.0 domain does not run the Active Directory service.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To resolve this problem, follow these steps:
  1. Locate the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters subkey.
  2. Right-click the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters subkey, point to New, click DWORD Value, and then type EnableLocalUser.
  3. Double-click EnableLocalUser.
  4. In the Edit DWORD Value dialog box, click Hexadecimal under Base.
  5. In the Edit DWORD Value dialog box, type 1 in the Value data box, and then click OK.
  6. Restart the applications that are using the Message Queuing service.

WORKAROUND

To work around this problem, change the Message Queuing client behavior to the Message Queuing 2.0 behavior by using RPC. Do this only for applications, not for the Message Queuing service itself. This change affects all the Message Queuing applications on a computer. This workaround also works if you log on as a local user.

MORE INFORMATION

Steps to reproduce the problem

To reproduce the problem, follow these steps:
  1. Create a Windows NT 4.0 domain.
  2. Create a Windows 2000 domain.
  3. Setup a trust relationship between the Windows NT 4.0 domain and the Windows 2000 domain.

    For additional information about how to setup a trust relation between a Windows NT 4.0 domain and a Windows 2000 domain, click the following article number to view the article in the Microsoft Knowledge Base:

    306733 How to create a trust between a Windows 2000 domain and a Windows NT 4.0 domain

  4. Log on to the Windows 2000 domain by using a Windows NT 4.0 user account, and then create several public queues.
  5. Log on to the Windows XP computer by using the Windows NT 4.0 user account, and then access the public queues.

    You may receive the error message that is mentioned in the "Symptoms" section.

REFERENCES

For additional information, visit the following Microsoft Web site:

MSMQ frequently asked questionsFor additional information about public queues, visit the following Microsoft Developer Network (MSDN) Web site:For additional information about Message Queuing, visit the following MSDN Web site:

Modification Type:MajorLast Reviewed:2/9/2006
Keywords:kbdomain kbActiveDirectory kbsetup kbprb KB840146 kbAudDeveloper