You cannot install the Terminal Services CAL pack on a Windows 2000 server-based computer (839878)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to install the Terminal Services Client Access License (CAL) pack on a Microsoft Windows 2000-based server, you may receive the following error message:
Licensing Wizard was unable to install the client license key pack. Please verify your entry and try this operation again. Message Number 0x13A7.
Note The message number may also be 0x13A4 or 0xFA1.

The following event ID error message may be logged in the application event log: Event ID: 41
Source: TermServLicensing
Description: Can't initialize policy module because of error 'Missing Policy module registry entry for product Microsoft Corporation, company 004'

CAUSE

This problem may occur for one or more of the following reasons:
  • Cause 1: You are trying to install a Microsoft Windows Server 2003 CAL pack on a Windows 2000-based license server.
  • Cause 2: The Terminal Services Licensing component is corrupted or missing.
  • Cause 3: The Terminal Services registry key has incorrect settings.

RESOLUTION

Cause 1: You are trying to install a Windows Server 2003 CAL pack on a Windows 2000-based license server

Because you cannot install a Windows Server 2003 CAL pack on a Windows 2000-based license server, you must use one of the following options to resolve this problem:
  • Install the Terminal Services Licensing component on a Windows Server 2003-based computer, and then install the Windows Server 2003 CAL pack on the Windows Server 2003 license server.
  • Keep the Terminal Services Licensing component on a Windows 2000-based license server. To do this, use one of the following options:
    • Contact the retailer if you obtained the CAL pack through a retail channel.
    • Contact the Microsoft Registration Authority and Clearinghouse to downgrade the Terminal Services License CAL pack to be compatible with Microsoft Windows 2000 Terminal Servers.

      To contact the Registration Authority and Clearinghouse in the United States, call (888) 571-2048.

      To access the Registration Authority and Clearinghouse from outside the United States, follow these steps:
      1. Click Start, point to Programs, click Administrative Tools, and then click Terminal Services Licensing.
      2. In the Terminal Services Licensing console, right-click your license server, and then click Properties.
      3. Click Connection Method, and then click Telephone.
      4. Click the appropriate country, and then click OK.
      5. On the Action menu, click Install Licenses, and then click Next.
      6. Call the appropriate Customer Service Center by using the telephone number that is displayed.
      7. Click Cancel to exit the Terminal Services Licensing console.

Cause 2: The Terminal Services Licensing component is corrupted or missing

If the Terminal Services Licensing component (Tls236.dll) is corrupted or missing, remove the component and then reinstall it. To do this, use the following two-part procedure.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Part 1: Remove the Terminal Services Licensing component

  1. Click Start, Point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click Add/Remove Windows Components.
  4. In the Windows Components Wizard, click to clear the Terminal Services Licensing check box, and then click Next.
  5. Click Finish.
  6. Rename the %windir%\System32\Lserver folder, where %windir% is the path of your Windows folder.

    For example, rename %windir%\System32\Lserver to %windir%\System32\Lserver2.
  7. Delete the MSLicensing subkey from the registry. To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing

    3. Right-click MSLicensing, and then click Delete.
    4. Quit Registry Editor.

Part 2: Reinstall the Terminal Services Licensing component

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click Add/Remove Windows Components.
  4. In the Windows Components Wizard, click to select the Terminal Services Licensing check box, and then click Next.
  5. Click Your entire enterprise or click Your domain or workgroup.
  6. Select the license server database location, and then click Next.
  7. Click Finish.

Cause 3: The Terminal Services registry key has incorrect settings

To verify that the Terminal Services Licensing registry key contains the correct settings, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TermServLicensing\Policy\Microsoft Corporation\A02

  3. Make sure that the registry subkey contains the following entry:
    • String Name: DLL
    • String Value: %systemroot%\System32\tls236.dll
  4. If the DLL entry does not contain the correct value data, modify the value. To do this, follow these steps:
    1. In Registry Editor, right-click DLL, and then click Modify.
    2. In the Value data box, type %systemroot%\System32\tls236.dll, and then click OK.
  5. If the registry subkey does not contain the DLL entry, you must manually add it. To do this, follow these steps:
    1. In Registry Editor, right-click the following registry subkey:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TermServLicensing\Policy\MicrosoftCorporation\A02

    2. Point to New, and then click String Value.
    3. Type DLL, and then press ENTER.
    4. Right-click DLL, and then click Modify.
    5. In the Value data box, type the following, and then click OK:

      %systemroot%\System32\Tls236.dll

  6. Quit Registry Editor.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:12/6/2004
Keywords:kbprb KB839878 kbAudITPRO