Universally unique identifiers that are returned contain the same seed value in Windows Server 2003 (839638)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

You may experience one of the following symptoms:
  • When you call the ExUUIDCreate routine in kernel mode, all the universally unique identifiers (UUID) that are returned by the call may have the same seed value. The seed value is the last twelve characters of the UUID.
  • When you use the Uuidgen command-line utility with the -x parameter to force serial UUIDs, all the UUID values that are generated may have the same seed value.
The seed value that is repeated is 505054503030. These 12 characters are the ASCII representation of the seed value PPTP00.

CAUSE

This problem may occur if the Network Driver Interface Specification (NDIS) wide-area network (WAN) miniport drivers do not support the OID_GEN_VENDOR_ID object. The OID_GEN_VENDOR_ID object specifies a three-byte vendor code that is followed by a single byte that the vendor assigns to identify a particular network adaptor. The vendor code that is specified is a vendor code that is registered with the Institute of Electrical and Electronics Engineers, Inc. (IEEE). The IEEE code uniquely identifies the vendor and is the same as the three bytes that appear at the beginning of the network adaptor hardware address. Vendors that do not have an IEEE-registered code are expected to use the value 0xFFFFFF. These vendors are expected to use this value so that the value is correctly interpreted by the UUID creation code. This problem occurs if the value that is returned is 0x00000000 instead of 0xFFFFFFFF. Because the value 0x00000000 is returned, the UUIDs that are generated are not unique.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit versions

Date         Time   Version            Size    File name
--------------------------------------------------------------
03-May-2004  23:46  5.2.3790.169       38,912  Raspppoe.sys
04-May-2004  00:33  5.2.3790.169       68,096  Raspptp.sys

Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version           Size     File name
--------------------------------------------------------------
03-May-2004  23:46  5.2.3790.169      118,272  Raspppoe.sys
03-May-2004  23:46  5.2.3790.169      181,760  Raspptp.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB839638 kbAudDeveloper