Group Policy setting that prevents use of the Internet Connection Firewall is not enforced in Windows XP or in Windows Server 2003 with SP1 (839551)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

When your Group Policy setting prevents the use of the Internet Connection Firewall (ICF) in Microsoft Windows XP or in Microsoft Windows Server 2003 with Service Pack 1 (SP1), the Netman.dll file may not enforce that policy.

CAUSE

This problem may occur when a registry subkey value is null. If you use Group Policy slow link detection and set the connection speed to zero, the following subkey may be null:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\GroupPolicy\History\NetworkName

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Apr-2004  06:42  5.1.2600.1513     675,840  Userenv.dll      x86
   06-Apr-2004  06:35  5.1.2600.1513   1,714,176  Userenv.dll      IA-64

STATUS

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must have Service Pack 1 installed to install this hotfix.. Restart requirementYou must restart your computer after install this hotfixHotfix replacement informationThis hotfix does not replace any other hotfix.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Windowsserver2003-kb839551-x86-enu.exe1.0.0.0716,52817-Aug-200515:40x86NoneNot Applicable
Userenv.dll5.2.3790.2510790,01617-Aug-200515:12x86SP1SP1QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.25101,069,56817-Aug-200515:34x64SP1SP1QFE
Wuserenv.dll5.2.3790.2510790,01617-Aug-200515:34x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Windowsserver2003-kb839551-ia64-enu.exe1.0.0.01,562,35217-Aug-200515:39x86NoneNot Applicable
Userenv.dll5.2.3790.25101,564,67217-Aug-200515:34IA-64SP1SP1QFE
Wuserenv.dll5.2.3790.2510790,01617-Aug-200515:34x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:10/3/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB839551 kbAudITPRO