File copy operations to a DFS share perform slowly in Windows Server 2003 or in Windows XP (839231)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition

SYMPTOMS

When you copy files from Microsoft Windows Server 2003 or from Microsoft Windows XP to a Microsoft distributed file system (DFS) share or to a Samba DFS share, the file copy process is very slow. This problem occurs when you copy files to the DFS share, and you specify explicit credentials. If you copy files from the DFS share, you do not experience this problem.

CAUSE

This problem occurs if you explicitly specify the credentials to use when you connect to the DFS share. In this scenario, a new TCP session and an SMB session is opened four times for every file that is copied to the DFS share. A NetBIOS session may also open four times for every file that is copied to the DFS share.

RESOLUTION

Hotfix information

Microsoft Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

Date         Time   Version            Size    File name
--------------------------------------------------------
24-Mar-2004  22:28  5.2.3790.144      106,496  Mup.sys


Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version            Size    File name
---------------------------------------------------------
24-Mar-2004  22:19  5.2.3790.144      304,640  Mup.sys

Microsoft Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP Service Pack 1 (SP1) installed to apply this hotfix. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart your computer to apply the changes after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-bit editions

Date         Time   Version            Size    File name
--------------------------------------------------------
22-Mar-2004  3:33   5.1.2600.1366     104,704  Mup.sys


Windows XP, 64-Bit Edition

Date         Time   Version            Size    File name
---------------------------------------------------------
22-Mar-2004  3:12   5.1.2600.1366     354,176  Mup.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB839231 kbAudITPRO