The Dynamic Help feature does not work in Visual Studio .NET 2002 on a computer that is running Windows NT 4.0 (839067)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition
  • the operating system: Microsoft Windows NT 4.0 SP6a

SYMPTOMS

You log on to a computer that is running Microsoft Windows NT 4.0. The computer has Service Pack 6a (SP6a) installed, and your user account is not a member of the Administrators group. When you apply the Windows NT 4.0 Security Rollup Package (Security Update, July 26, 2001) and then start Microsoft Visual Studio .NET 2002, you notice the following behavior:
  • You may not be able to use the Dynamic Help feature in Visual Studio .NET.
  • You may not be able to see the icons for all products that are installed as part of Visual Studio .NET.
  • The size of the Visual Studio .NET splash screen may be longer than the size that it typically appears.
  • You may not be able to customize the personal settings on the start page of Visual Studio .NET.

CAUSE

When you apply the Windows NT 4.0 Security Rollup Package (Security Update, July 26, 2001) on your computer, some registry keys that are required to run the Dynamic Help feature in Visual Studio .NET 2002 become read-only for a user account that is not a member of the Administrators group. To use the Dynamic Help feature in Visual Studio .NET 2002, you must have write permissions for these registry keys.

RESOLUTION

To resolve this problem, install Microsoft Internet Explorer 6.0 and the latest service pack for Internet Explorer 6.0. For more information about Internet Explorer, and to obtain Internet Explorer service packs and updates, visit the following Microsoft Web site:

REFERENCES

For more information, visit the following Microsoft Web sites: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot


Modification Type:MinorLast Reviewed:2/3/2006
Keywords:kbvs2005swept kbvs2005doesnotapply kbtshoot kbprb kbService kbRegistry kbpatch kbhelpfile kbDynamic kbSecurity kbhelp KB839067 kbAudDeveloper