The Systems Management Server 2003 Advanced Client does not report file details in software inventory (838471)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you view the Software Inventory data for the Microsoft Systems Management Server (SMS) 2003 Advanced Client, the following details may be missing from Resource Explorer:
  • File Version
  • File Description
  • Product Version
  • Product Name
Additionally, the FSInvProvider.log file may contain error messages that are similar to the following:
Could not read string "ProductVersion" from file FileName - 1168
Couldn't read file FrameworkService.exe resource block with code page = 1033, language = 1252; no alternate values found in string table. Full set of resource strings not found in FrameworkService.exe

CAUSE

This problem occurs when the following values are missing from the version information strings that are in the file that you are trying to inventory:
  • Product Name
  • Product Version
  • Company Name

Note This problem does not occur on SMS 2003 Legacy Client computers.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Version          Size    File name
------------------------------------------------------------
30-Apr-2004  18:34                     13,167  Filemap.ini
20-Feb-2004  15:03    2.0.6.7         355,242  Smsupdate.exe    
25-Dec-2003  07:45    2.50.2726.121    59,904  Fsinvprv.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Installation instructions

This hotfix will update the Advanced Client SMS Inventory Agent and the SMS Client to version 2.50.2726.0121. To view version information for the SMS 2003 Advanced Client computer, open Systems Management in Control Panel, and then click the Components tab.

You must apply this hotfix to all SMS 2003 Advanced Clients in your SMS hierarchy. Depending upon your SMS hierarchy configuration, you may want to complete these steps on primary site servers and on secondary site servers to make sure that the hotfix is distributed to all Advanced Client computers. To install this hotfix, follow these steps:
  1. Create a shared folder in a location that is accessible to your SMS site servers.
  2. Copy the SMS2003-RTM-KB838471-X86-ENU.exe hotfix file to the shared folder.
  3. Use an account that has administrative credentials to log on to the site server.
  4. Quit the SMS Administrator Console if the Console is running.
  5. Run the SMS2003-RTM-KB838471-X86-ENU.exe update file, and then follow the instructions in the hotfix installation wizard.

    Note Make sure to review the Applying hotfixes to SMS Advanced Clients information that appears in the installation wizard.
  6. When prompted by the installation wizard to create a package and a program to help in deploying this hotfix, click Yes, I want to create a package and program now, and then click Next.
  7. On the Create a Package and Program page, accept the defaults or type a new name for the package and the program. Click Next.
  8. On the Specify Package Source Location... page, accept the defaults or change the location of the package source files. Click Next.
  9. Make sure that you read the Applying hotfixes to SMS Advanced Clients information, click Next, and then click Finish.
  10. Start the SMS Administrator Console.
  11. Expand Site Hierarchy\your site\Site Settings, where your site is the name of your SMS site, and then click Client Agents.
  12. Right-click Software Inventory Client Agent, and then click Properties.
  13. On the General tab of the Software Inventory Client Agent Properties dialog box, make sure that Enable software inventory on clients is selected.
  14. Click the Inventory Collection tab, and then click the Add asterisk.
  15. In Inventoried File Properties, type Fsinvprv.dll in the Name field, click OK, and then click OK again.
  16. Wait a minimum of two days for the software inventory process to complete on all the SMS 2003 Advanced Client computers.

    Important Software inventory must be completed before you continue to the next step.
  17. After software inventory is completed on all clients, start the SMS Administrator Console, expand Site Database (your site), right-click the Collection node, click New, and then click Collection.
  18. In the Collection Properties dialog box, type a descriptive name in the Name field.
  19. Click the Membership Rules tab, and then click the yellow database button to open Query Rule Properties.
  20. In Query Rule Properties, type a name for the query in the Name field, and then click Edit Query Statement.
  21. On the General tab of the Query Statement Properties dialog box, click Show Query Language.
  22. Delete the existing query statement, and then copy and paste the following query in the Query Statement field:
    select SMS_G_System_COMPUTER_SYSTEM.Name,
    SMS_G_System_SoftwareFile.FileName,
    SMS_G_System_SoftwareFile.FileVersion,
    SMS_G_System_SoftwareFile.FileDescription,
    SMS_G_System_SoftwareFile.FileSize,
    SMS_G_System_SoftwareFile.FilePath from
    SMS_R_System inner join SMS_G_System_COMPUTER_SYSTEM on SMS_G_System_COMPUTER_SYSTEM.ResourceID = SMS_R_System.ResourceId inner join
    SMS_G_System_SoftwareFile on SMS_G_System_SoftwareFile.ResourceID = SMS_R_System.ResourceId where SMS_G_System_SoftwareFile.FileName = " Fsinvprv.dll " and
    SMS_G_System_SoftwareFile.FileVersion < "2.50.2726.0121"
  23. Click OK three times.
  24. In the SMS Administrator Console, expand Site Database (your site), right-click Advertisements, point to New, and then click Advertisement.
  25. In Advertisement Properties, type a descriptive name in the Name field.
  26. Click the Package list, and then click KB838471 - Advanced Client Hotfix - SiteCode, where SiteCode is the code of your SMS site.
  27. Click the Program list, and then click KB 838471 - Advanced Client Patch Install.
  28. Click Browse, and then click the collection that you created in step 17. Click OK two times.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMSTopazFix KB838471 kbAudITPRO