SYMPTOMS
When you run the Security Translation Wizard in the Active Directory Migration Tool (ADMT), you may receive the following error message:
Specified domain does not exist or could not be contacted.
If you run the ADMT at a command line, you receive the following error messages:
ERR3:7233 Cannot get source or target domain information...aborting.
ERR2:7010 The Active Directory Migration Tool cannot look up the SID for domain your_domain.
CAUSE
This problem may occur if the domain that you try to migrate is no longer available. However, this functionality is documented in the "Decommission Source Domains" section of the Readme.doc file, as follows:
During security translation, ADMT v-1 communicates with the source domain that is referenced on the access control list (ACL) of the object. If the source domain is already decommissioned, the security translation fails. ADMT v-2 stores all necessary information in a database so that security translations are successful even after source domains are decommissioned.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
You must have the Active Directory Migration Tool v2.0 installed.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement
information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later) that are listed in
the following table. The dates and times for these files are listed in coordinated
universal time (UTC). When you view the file information, it is converted to local time. To
find the difference between UTC and local time, use the
Time Zone tab in
the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------------------------
09-Mar-2004 16:56 5.2.3790.139 464,384 Mcsdctworkerobjects.dll
09-Mar-2004 16:56 5.2.3790.139 211,968 Mcsmigrationdriver.dll
09-Mar-2004 16:56 5.2.3790.139 845,312 Wizards.dll
Note When you extract the files, you must manually specify the location that contains the existing ADMT files.
To install this hotfix, copy the Mcsdctworkerobjectsnt4.dll file to the NT4Agent\Mcsdctworkerobjects.dll location under the folder that contains the ADMT. By default, this folder is C:\Program Files\Active Directory Migration Tool.