"Data provider or other service returned an E_FAIL status" error message when you export a document library in Windows SharePoint Services to an Excel workbook (838048)



The information in this article applies to:

  • Microsoft Windows SharePoint Services

SYMPTOMS

When you connect to a document library in a Microsoft Windows SharePoint Services Web site, and then click Export to spreadsheet to export the list of documents in the document library to a Microsoft Excel workbook, you may receive the following error message:
Data provider or other service returned an E_FAIL status.
When you click OK on the error message, the workbook is empty. The list of documents in the document library are not imported to the Excel workbook.

CAUSE

This issue may occur if you are running Microsoft Excel 2002. Although you can export a document library from a Windows SharePoint Services Web site to a Microsoft Office Excel 2003 workbook, you cannot export a document library from a Windows SharePoint Services Web site to an Excel 2002 workbook.

WORKAROUND

To work around this issue, modify the query and then import the data into Excel 2002. To do this, follow these steps:
  1. After you receive the error message that is mentioned in the "Symptoms" section, click OK.
  2. On the Data menu, point to Import External Data, and then click Edit Query.
  3. Click the yellow arrow icon next to each item that you want to import. When you click a yellow arrow icon, the icon changes into a check mark icon.
  4. Click Import.

MORE INFORMATION

For more information about Windows SharePoint Services, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kberrmsg kbnofix kbBug KB838048 kbAudITPRO