RAW Dynamic disk mirrored volumes or RAW RAID-5 volumes regenerate after every shutdown (837640)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

After you restart a Microsoft Windows 2000-based computer that has RAW Dynamic disk mirrored volumes or RAW RAID-5 volumes, your volumes may resynchronize. Although the Disk Management snap-in typically shows the Resynching status of RAW Dynamic disk mirrored volumes or of RAW RAID-5 volumes only after an unexpected restart operation or a system crash, the resynchronizing operation may occur after every shutdown. This resynchronizing operation occurs if a write operation was performed on the RAW Dynamic disk mirrored volumes or on the RAW RAID-5 volumes before the shutdown. This symptom does not occur on volumes that contain a formatted file system such as the following file systems:
  • FAT
  • FAT32
  • NTFS file system
Note A RAW volume is a volume that was never formatted and does not contain a file system such as FAT, FAT32, or NTFS. A RAW volume is typically written to by a program that does not require a file system. The program performs direct I/O to the RAW volume instead. For example, Microsoft SQL Server does not require a file system. It performs direct I/O to the RAW volume instead.

CAUSE

This problem may occur if one or more RAW volumes were not registered for shutdown notification. Therefore, the volume or volumes appear to have been shutdown "dirty."

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size     File name
   -------------------------------------------------------
   24-Feb-2004  22:42  2195.6901.297.3  138,640  Dmio.sys

WORKAROUND

To work around this problem, format the RAW volume or volumes by using one of the following supported file systems:
  • FAT
  • FAT32
  • NTFS
Note You cannot work around this problem by using RAW volumes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB837640 kbAudITPRO