Troubleshooting profile unload issues (837115)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

SYMPTOMS

When you log off a computer that is running Microsoft Windows Server 2003, Windows XP, Windows 2000, or Windows NT 4.0, you may experience one or more of the following symptoms:
  • A user profile does not unload.
  • A roaming profile does not reconcile.
  • You reach the registry size limit (RSL).
  • You take a long time to log off, and you receive the following message: Saving settings..
  • Backups may not start. There are no errors in the Application log from the Backup program. However, if you see event ID 1524, the Backup has not run.
Additionally, you may receive one or more of the following event messages in the application event log, depending on your operating system.

Windows XP and Windows Server 2003Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1517
Description:
Windows saved user ComputerName\UserName registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use. This is caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account. Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1524 Description:
Windows cannot unload your classes registry file - it is still in use by other applications or services. The file will be unloaded when it is no longer in use. Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1500
Description:
Windows cannot log you on because your profile cannot be loaded. Check that you are connected to the network, or that your network is functioning correctly. If this problem persists, contact your network administrator.
Details:
------------------------------
Access is denied Windows 2000Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Description:
Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. Contact your administrator.
Details:
------------------------------
Access is denied Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Description:.
Windows cannot unload your registry class file. If you have a roaming profile, your settings are not replicated. Contact your administrator.
Details: -
-----------------------------
Access is denied Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Description:
Windows cannot log you on because the profile cannot be loaded. Contact your network administrator. Windows NT 4.0Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Description:
The operating system was unable to load your profile. Please contact your Network Administrator.
Details:
------------------------------
Access is denied.

CAUSE

This issue may occur if Microsoft Windows or third-party programs such as printer drivers or virus scanners do not stop and release resources when you log off your computer.

RESOLUTION

To resolve this issue, use the Microsoft User Profile Hive Cleanup Service (UPHClean). UPHClean monitors the computer while Windows is unloading user profiles and forces resources that are open to close. Therefore, the computer can unload and reconcile user profiles.

To download and install UPHClean, visit the following Microsoft Web site:

MORE INFORMATION

For additional information about UPHClean, view the Readme.txt file. To download the file, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/3/2006
Keywords:kbServiceProcess kbwinservperf kbProfiles kbprb KB837115 kbAudEndUser kbAudITPRO