MOM scripts quit unexpectedly on a clustered Exchange Server 2003 computer (837042)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

After you configure Microsoft Operations Manager (MOM) to monitor a Microsoft Exchange Server 2003 virtual server that is configured on a server cluster, you notice that MOM does not receive mail flow reports from the server cluster as expected. When you investigate this issue, you verify that the MOM scripts are not running or that these scripts quit unexpectedly, and therefore they do not generate the reports.

CAUSE

This problem occurs if you have more than one network name resource configured in the Exchange Server resource group. All the MOM scripts that require a mailbox in the Exchange Server information store must determine the correct mailbox name. These scripts determine the mailbox name by using the Exchange virtual server name, and this name is defined by the network name resource. If you have additional network name resources, the script may select an incorrect network name. In this scenario, the script quits because it cannot determine the mailbox name.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer if you follow the hotfix installation instructions from the "Hotfix installation information" section. However, if you install this hotfix directly on a server cluster, you must restart many services.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time               Size    File name
   ------------------------------------------------------------------------------------
   01-Apr-2004  03:15              30,263  Check_local_disks_free_space.vbs
   01-Apr-2004  03:15              12,927  Check_mailbox_store_state.js
   01-Apr-2004  03:15              16,155  Collect_database_size_per_server.vbs
   01-Apr-2004  03:16              25,809  Collect_mailbox_statistics.vbs
   01-Apr-2004  03:16              15,964  Collect_message_tracking_log_statistics.vbs
   01-Apr-2004  03:16              15,584  Collect_number_of_mailboxes_per_server.vbs
   01-Apr-2004  03:16              30,875  Collect_public_folder_statistics.vbs
   01-Apr-2004  03:16              29,744  Collect_server_information.vbs    
   01-Apr-2004  03:16              34,979  Mail_flow_receiver.js
   01-Apr-2004  03:16              23,137  Mail_flow_sender.js
   01-Apr-2004  03:16              34,004  Mapi_logon_verification.js
   01-Apr-2004  03:16              16,634  Verify_age_of_transaction_log_files.vbs
   01-Apr-2004  03:16              18,545  Verify_circular_logging_disabled.vbs
   01-Apr-2004  03:16              18,706  Verify_config_of_fe_servers.vbs
   01-Apr-2004  03:16              18,992  Verify_if_ssl_should_be_required.vbs
   01-Apr-2004  03:16              15,202  Verify_message_tracking_enabled.vbs
   01-Apr-2004  03:16              14,143  Verify_message_tracking_share_protected.vbs
   01-Apr-2004  03:16              16,266  Verify_server_cannot_anonymously_relay.vbs
   01-Apr-2004  03:16              16,987  Verify_smtp_dirs_on_ntfs_drive.vbs
   01-Apr-2004  03:16              26,787  Verify_test_mailboxes.vbs
   01-Apr-2004  03:16              22,222  Verify_transaction_logs_not_on_db_drive.vbs
   01-Apr-2004  03:16              13,255  Verify_urlscan_running.vbs

Hotfix installation information

To install this hotfix, follow these steps:
  1. Run the hotfix package to install the hotfix files on an Exchange Server 2003 computer that is not configured on a server cluster.

    Note The hotfix installation package extracts the replacement script files to the following location on your Exchange Server computer:

    Program Files\exchsrvr\837042

    Microsoft recommends that you do not install this package directly on a clustered Exchange Server computer so that you do not have to restart services on the computer.
  2. Copy the script files to a temporary location on the MOM Data Access Server/Consolidator-Agent Manager (DCAM) server.
  3. Replace the existing MOM scripts. To do so:
    1. Start the MOM Administrator Console tool.
    2. For each existing script, select the script contents, and then paste that content into a new file as a backup.
    3. Paste the new script into the MOM Administrator Console window.
  4. After you have replaced all the scripts, right-click Rules in the MOM Administrator Console tool, and then click Commit Configuration Change. The process starts to update the MOM agents on your Exchange Server computers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, the new script files search the Active Directory directory service for the correct Exchange Server virtual server name to determine the mailbox name from. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 XADM: New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbClustering kbQFE kbfix kbBug kbExchange2003preSP1fix KB837042 kbAudITPRO