Error messages are not displayed in the foreground when you try to connect to a resource by typing its UNC path in the Open box of the Run command in Windows Server 2003, Windows XP, and Windows 2000 (836532)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Datacenter Server SP4
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

SYMPTOMS

When you click Start, click Run, and then try to connect to a resource by typing a Universal Naming Convention (UNC) path (for example, \\server name\share name) in the Open box, error messages may not appear in the foreground if you immediately switch to another program.

CAUSE

This behavior occurs because the error message dialog box is hidden behind the maximized window that has the focus.

WORKAROUND

To work around this behavior, minimize all windows while you wait for Microsoft Windows to make a connection so that the error message dialog box can appear.

STATUS

This behavior is by design.

MORE INFORMATION

The focus behavior of the foreground and background programs has been modified in the versions of Windows that are shown in the "Applies To" section. The new focus behavior prevents the non-active program from sending dialog boxes to the foreground. In this way, the active program does not lose the focus. When you try to connect to a resource by using the method that is described in the "Symptoms" section, Windows Explorer is started, but it does not appear until the connection is either successful or unsuccessful. If you switch to another program before Windows Explorer presents the results, Windows Explorer or an error message dialog box will appear in the background, behind the program that you switched to.

Modification Type:MajorLast Reviewed:4/9/2004
Keywords:kbprb KB836532 kbAudEndUser