Duplicate BizTalk Server 2004 entries appear in the PATH system environment variable on your computer (836467)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Standard Edition

SYMPTOMS

On your computer that is running Microsoft BizTalk Server 2004, you may notice that some BizTalk Server 2004 path entries appear multiple times in the PATH system environment variable. For example, the following path entry may appear multiple times:

C:\Program Files\Microsoft BizTalk Server 2004\;

Also, when you try to install other programs on your computer, you may receive error messages.

CAUSE

This behavior may occur if you remove and then reinstall BizTalk Server 2004. When you first install BizTalk Server 2004, the installation process adds many entries to the PATH system environment variable. However, when you remove BizTalk Server 2004, the BizTalk Server 2004 path entries are not removed. Therefore, when you reinstall BizTalk Server 2004, duplicate BizTalk Server 2004 path entries are added to the PATH variable.

If you remove and then reinstall BizTalk Server 2004 many times, the value of the PATH variable may reach its maximum length. If the value of the PATH variable reaches its maximum length, you may receive an error message when you try to install another program that must append a new path entry to the PATH variable.

WORKAROUND

To work around this behavior, manually remove the duplicate BizTalk Server 2004 path entries from the PATH system environment variable. To do this, follow these steps:
  1. On your desktop, right-click My Computer, and then click Properties.
  2. In the Properties dialog box, click the Advanced tab.
  3. On the Advanced tab, click Environment Variables.
  4. Under System variables, click Path, and then click Edit.
  5. In the Variable value box, delete the duplicate BizTalk Server 2004 path entries, and then click OK.
  6. Restart your computer.

MORE INFORMATION

Steps to reproduce the behavior

  1. On your desktop, right-click My Computer, and then click Properties.
  2. In the Properties dialog box, click the Advanced tab.
  3. On the Advanced tab, click Environment Variables.
  4. Under System variables, click Path, and then click Edit.

    Notice the value of the PATH variable.
  5. Install BizTalk Server 2004.
  6. Repeat steps 1 through 4.

    Notice the additions to the value of the PATH variable.
  7. Remove BizTalk Server 2004.
  8. Repeat steps 1 through 4.

    Notice that the BizTalk Server 2004 path entries are not removed from the value of the PATH variable.
  9. Reinstall BizTalk Server 2004.
  10. Repeat steps 1 through 4.

    Notice that duplicate BizTalk Server 2004 path entries appear in the value of the PATH variable.

Modification Type:MajorLast Reviewed:3/2/2004
Keywords:kbsetup kbprb KB836467 kbAudITPRO kbAudDeveloper