You cannot open the device Explorer window by using the ActiveSync toolbar in Windows (836152)



The information in this article applies to:

  • Microsoft ActiveSync 3.5
  • Microsoft ActiveSync 3.6
  • Microsoft ActiveSync 3.7

SYMPTOMS

When you click the Explore button on the ActiveSync toolbar in Microsoft Windows, the device Explorer window does not open.

CAUSE

This problem occurs because the Windows shell policy on your computer disables shell name extensions that are not trusted.

The shell policy sets the value of the EnforceShellExtensionSecurity key to 1. This setting causes the shell to run only the shell extensions that are registered under the Approved key.

RESOLUTION

To enable the device explorer, add the ActiveSync extension to the list of trusted extensions. To do this, follow these steps:
  1. Open a text editor such as Notepad, and then paste the following text in a blank document:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{49BF5420-FA7F-11cf-8011-00A0C90A8F78}"="Mobile Device"

  2. Save the file. Type .reg for the file name extension.
  3. Locate and then double-click the file.
  4. When you receive a message to add information to the registry, click Yes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information about approved shell extensions and the EnforceShellExtensionSecurity key, click the following article number to view the article in the Microsoft Knowledge Base:

216384 Approved shell extensions only enforced if EnforceShellExtensionSecurity key is turned on


Modification Type:MajorLast Reviewed:5/13/2004
Keywords:kbprb KB836152 kbAudDeveloper